<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":479,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81735490-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>IowaPreps.com  -  Top 250 Basketball Players in 2018 (31-35)</title>
<meta content='IowaPreps.com  -  Top 250 Basketball Players in 2018 (31-35)' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-bd8e0400049933d7d82b6800a27663d3f82104735ca93ffa4c021e578eb2a73b.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="nChui3bA2G4UNe82aDEQuHGXefx57/PJ6acqVRTrMAi7er4+x/gnYuLIeBrW8aVX2pxACVLJnMl6GTcmkTObrQ==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1' property='og:url'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_thumbnail/h2ove77sa8xmqg5kkl8w' property='og:image'>
<meta content='Who are the top in-state basketball players within the Class of 2018? Iowa Preps answers that question now!' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-04-16 06:30:00 -0500' property='article:published_time'>
<meta content='2018-04-11 15:18:32 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "iowapreps.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='iowapreps contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .iowapreps #programming > h1 {
      background-color: #000000 !important; } }
  .iowapreps > header .notification-link .count-container {
    background-color: #000000 !important; }
  .iowapreps > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .iowapreps > header .wrapper-container {
        border-bottom: 5px solid #b22222 !important; } }
  .iowapreps > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .iowapreps > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .iowapreps > header .invalid-email-banner a:hover {
      color: #b22222; }
  @media screen and (max-width: 767px) {
    .iowapreps > header .mobile-header {
      background-color: #b22222 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .iowapreps > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .iowapreps > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .iowapreps > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .iowapreps > header .nav-row > ul,
    .iowapreps > header .third-nav {
      background-color: white !important; }
    .iowapreps > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .iowapreps > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #b22222; }
  
  .site-secondary-background-color {
    background-color: #b22222; }
  
  :root {
    --outbrain-primary-color: #000000;
    --outbrain-secondary-color: #b22222; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Iowa HS Sports" class="school-header" href="//iowapreps.rivals.com"><img src="https://res-3.cloudinary.com/rivals/image/upload/mvavgkj1liboqerv0d8s" alt="Mvavgkj1liboqerv0d8s" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//iowapreps.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;iowapreps&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//iowapreps.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;iowapreps&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719658,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Top 250 Basketball Players in 2018 (31-35)"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='Top 250 Basketball Players in 2018 (31-35)' name='twitter:title'>
<meta content='Who are the top in-state basketball players within the Class of 2018? Iowa Preps answers that question now!' name='twitter:description'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/h2ove77sa8xmqg5kkl8w' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1910190,"title":"Top 215 Basketball Players in 2019 (56-60)","slug":"top-215-basketball-players-in-2019-56-60-","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-16T01:01:00.000-05:00","summary":"Who are the top in-state basketball players within the Class of 2019? Iowa \r\nPreps answers that question now!Rank Name","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-215-basketball-players-in-2019-56-60-","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910880,"title":"Preseason All State Baseball - 3A Catchers","slug":"preseason-all-state-baseball-3a-catchers-1","kind":"free","site_id":54,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T18:30:00.000-05:00","summary":"Iowa Preps names our preseason all state Catchers now for the 2018 season!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/preseason-all-state-baseball-3a-catchers-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910838,"title":"Top 215 Basketball Players in 2019 (76-80)","slug":"top-215-basketball-players-in-2019-76-80--1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T17:00:00.000-05:00","summary":"Who are the top in-state basketball players within the Class of 2019? Iowa Preps answers that question now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-215-basketball-players-in-2019-76-80--1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910848,"title":"Sophomore All State Girl&#x0027;s Basketball - First Team","slug":"sophomore-all-state-girl-s-basketball-first-team-1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T15:30:00.000-05:00","summary":"Iowa Preps names our sophomore all state team from the girl&#x0027;s basketball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/sophomore-all-state-girl-s-basketball-first-team-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910875,"title":"2018 Lakes Baseball Preview","slug":"2018-lakes-baseball-preview-1","kind":"free","site_id":54,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T14:00:00.000-05:00","summary":"Iowa Preps previews the Lakes conference for the 2018 baseball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/2018-lakes-baseball-preview-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1912066,"title":"Dejean talks Martin Bros.","slug":"dejean-talks-martin-bros-","kind":"premium","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T12:30:00.000-05:00","summary":"OA-BCIG point guard Cooper Dejean has high hopes for what his Martin Bros. AAU squad can do this spring on the hardwood.","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/dejean-talks-martin-bros-","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910881,"title":"2018 WaMac East Softball Preview","slug":"2018-wamac-east-softball-preview","kind":"free","site_id":54,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T11:00:00.000-05:00","summary":"Iowa Preps previews the WaMac East conference for the 2018 softball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/2018-wamac-east-softball-preview","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910859,"title":"Top Returning 4A, District 5 Offensive Players","slug":"top-returning-4a-district-5-offensive-players-3","kind":"free","site_id":54,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T09:30:00.000-05:00","summary":"Iowa Preps takes an inside look at the top returning offensive players returning in Class 4A, District 5 now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-returning-4a-district-5-offensive-players-3","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910858,"title":"2018 Dubuque Wahlert Off-Season Preview","slug":"2018-dubuque-wahlert-off-season-preview-1","kind":"free","site_id":54,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T08:00:00.000-05:00","summary":"Iowa Preps takes an early look at Dubuque Wahlert football for the 2018 season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/2018-dubuque-wahlert-off-season-preview-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910831,"title":"Top 250 Basketball Players in 2018 (36-40)","slug":"top-250-basketball-players-in-2018-36-40--1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-15T06:30:00.000-05:00","summary":"Who are the top in-state basketball players within the Class of 2018? Iowa Preps answers that question now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-36-40--1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910879,"title":"Preseason All State Baseball - 4A Catchers","slug":"preseason-all-state-baseball-4a-catchers-1","kind":"free","site_id":54,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T18:30:00.000-05:00","summary":"Iowa Preps names our preseason all state Catchers now for the 2018 season!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/preseason-all-state-baseball-4a-catchers-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910837,"title":"Top 215 Basketball Players in 2019 (81-85)","slug":"top-215-basketball-players-in-2019-81-85--1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T17:00:00.000-05:00","summary":"Who are the top in-state basketball players within the Class of 2019? Iowa Preps answers that question now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-215-basketball-players-in-2019-81-85--1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910847,"title":"Freshmen All State Girl&#x0027;s Basketball - First Team","slug":"freshmen-all-state-girl-s-basketball-first-team-1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T15:30:00.000-05:00","summary":"Iowa Preps names our freshmen all state team from the girl&#x0027;s basketball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/freshmen-all-state-girl-s-basketball-first-team-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910865,"title":"Top Returning 8-Man, District 5 Defensive Players","slug":"top-returning-8-man-district-5-defensive-players-1","kind":"free","site_id":54,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T14:00:00.000-05:00","summary":"Iowa Preps takes an inside look at the top returning defensive players returning in 8-Man, District 5 now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-returning-8-man-district-5-defensive-players-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1912065,"title":"Harberts remains a sought-after target","slug":"harberts-remains-a-sought-after-target","kind":"premium","site_id":54,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T12:30:00.000-05:00","summary":"Dike-New Hartford offensive tackle Colton Harberts has worked hard to see a number of college coaches up close and get a","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/harberts-remains-a-sought-after-target","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910882,"title":"2018 WaMac West Softball Preview","slug":"2018-wamac-west-softball-preview","kind":"free","site_id":54,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T11:00:00.000-05:00","summary":"Iowa Preps previews the WaMac West conference for the 2018 softball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/2018-wamac-west-softball-preview","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910860,"title":"Top Returning 3A, District 5 Offensive Players","slug":"top-returning-3a-district-5-offensive-players-3","kind":"free","site_id":54,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T09:30:00.000-05:00","summary":"Iowa Preps takes an inside look at the top returning offensive players returning in Class 3A, District 5 now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-returning-3a-district-5-offensive-players-3","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910857,"title":"2018 Vinton-Shellsburg Off-Season Preview","slug":"2018-vinton-shellsburg-off-season-preview-1","kind":"free","site_id":54,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T08:00:00.000-05:00","summary":"Iowa Preps takes an early look at Vinton-Shellsburg football for the 2018 season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/2018-vinton-shellsburg-off-season-preview-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910830,"title":"Top 250 Basketball Players in 2018 (41-45)","slug":"top-250-basketball-players-in-2018-41-45--1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-14T06:30:00.000-05:00","summary":"Who are the top in-state basketball players within the Class of 2018? Iowa Preps answers that question now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-41-45--1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910845,"title":"Freshmen All State Boy&#x0027;s Basketball - First Team","slug":"freshmen-all-state-boy-s-basketball-first-team-1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-13T18:30:00.000-05:00","summary":"Iowa Preps names our freshmen all state team from the boy&#x0027;s basketball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/freshmen-all-state-boy-s-basketball-first-team-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910836,"title":"Top 215 Basketball Players in 2019 (86-90)","slug":"top-215-basketball-players-in-2019-86-90-1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-13T17:00:00.000-05:00","summary":"Who are the top in-state basketball players within the Class of 2019? Iowa Preps answers that question now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/top-215-basketball-players-in-2019-86-90-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]},{"id":1910846,"title":"Elite All State Girl&#x0027;s Basketball - First Team","slug":"elite-all-state-girl-s-basketball-first-team-1","kind":"free","site_id":54,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-04-13T15:30:00.000-05:00","summary":"Iowa Preps names our elite all state team from the girl&#x0027;s basketball season now!","deleted":false,"author_name":"Luke Feddersen","author_title":"Publisher","permalink":"https://iowapreps.rivals.com/news/elite-all-state-girl-s-basketball-first-team-1","site_name":"IowaPreps.com","type":"Content","programming":[],"associated_links":[]}], nil, 54, nil, true); subdomain = &#x0027;iowapreps&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #000000'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1' background-color='#000000' base-api-url='https://iowapreps.forums.rivals.com/' homepage='false' message-board-url='iowapreps.forums.rivals.com' pub-ad='null' size='size' space-id='2022719658' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1/printable' site-name='IowaPreps.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-04-16 06:30:00 -0500') }}</span>
<span class='article-header-sport'>basketball</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1913083/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Top 250 Basketball Players in 2018 (31-35)</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Luke Feddersen
&bull;
</span>
<span class='type-sm'>IowaPreps.com</span>
<div class='type-sm'>
<a href='//twitter.com/iowapreps' target='_blank'>@iowapreps</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/iowapreps'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>Who are the top in-state basketball players within the Class of 2018? Iowa Preps answers that question now!</p><p>Release Dates:</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 31-35</a> - 4/16</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 26-30</a> - 4/17</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 21-25</a> - 4/18</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 16-20</a> - 4/19</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 11-15</a> - 4/20</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 6-10</a> - 4/21</p><p><a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Rankings 1-5</a> - 4/22</p><p>SUBSCRIBERS: <a href="http://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">CLICK HERE TO READ THE ENTIRE ARTICLE!</a></p><p>--------------------------------------------------</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/h2ove77sa8xmqg5kkl8w)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/h2ove77sa8xmqg5kkl8w" alt="H2ove77sa8xmqg5kkl8w" />
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>What other coverage am I missing by not subscribing?<br></p><p> All State Honors</p><p> <a href="https://iowapreps.rivals.com/news/elite-all-state-boy-s-basketball-first-team-2">Elite First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-all-state-boy-s-basketball-first-team-1">Junior First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-all-state-boy-s-basketball-first-team-1">Soph First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-all-state-boy-s-basketball-first-team-1">Frosh First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/elite-all-state-boy-s-basketball-second-team-1">Elite Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-all-state-boy-s-basketball-second-team-1">Junior Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-all-state-boy-s-basketball-second-team-1">Soph Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-all-state-boy-s-basketball-second-team-1">Frosh Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-all-state-boy-s-basketball-third-team-1">Junior Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-all-state-boy-s-basketball-third-team-1">Soph Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-all-state-boy-s-basketball-third-team-1">Frosh Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/elite-all-state-boy-s-basketball-third-team-1">Elite Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/elite-all-state-boy-s-basketball-fourth-team-1">Elite Fourth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/elite-all-state-boy-s-basketball-fifth-team-1">Elite Fifth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-all-state-boy-s-basketball-fourth-team-1">Frosh Fourth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-all-state-boy-s-basketball-fifth-team-1">Frosh Fifth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-all-state-boy-s-basketball-fourth-team-1">Junior Fourth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-all-state-boy-s-basketball-fifth-team-1">Junior Fifth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-all-state-boy-s-basketball-fourth-team-1">Soph Fourth Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-all-state-boy-s-basketball-fifth-team-1">Soph Fifth Team</a></p><p> Early 2018-2019 Team Rankings</p><p> <a href="https://iowapreps.rivals.com/news/2018-2019-preseason-4a-basketball-rankings-version-2-0-1">Class 4A</a></p><p> <a href="https://iowapreps.rivals.com/news/2018-2019-preseason-3a-basketball-rankings-version-2-0-1">Class 3A</a></p><p> <a href="https://iowapreps.rivals.com/news/2018-2019-preseason-2a-basketball-rankings-version-2-0-1">Class 2A</a></p><p> <a href="https://iowapreps.rivals.com/news/2018-2019-preseason-1a-basketball-rankings-version-2-0-1">Class 1A</a></p><p> Postseason Awards</p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-20">Mr. Basketball</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-senior-basketball-player-of-the-year">Senior of the Year</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-junior-basketball-player-of-the-year">Junior of the Year</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-sophomore-basketball-player-of-the-year">Soph of the Year</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-freshman-basketball-player-of-the-year">Freshman of the Year</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-basketball-coach-of-the-year-1">Coach of the Year</a></p><p> Final Team Rankings</p><p> <a href="https://iowapreps.rivals.com/news/final-class-4a-basketball-rankings-9">Class 4A</a></p><p> <a href="https://iowapreps.rivals.com/news/final-class-3a-basketball-rankings-9">Class 3A</a></p><p> <a href="https://iowapreps.rivals.com/news/final-class-2a-basketball-rankings-9">Class 2A</a></p><p> <a href="https://iowapreps.rivals.com/news/final-class-1a-basketball-rankings-9">Class 1A</a></p><p> Top 10 Candidates in 2019</p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2019-part-one">Part 1</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2019-part-two">Part 2</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2019-part-three">Part 3</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2019-part-four">Part 4</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2019-part-five">Part 5</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2019-part-six">Part 6</a></p><p>Top Class of 2021 Players</p><p> <a href="https://iowapreps.rivals.com/news/top-point-guards-in-2021-10">Top Point Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-guards-in-2021-7">Top Wing Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-forwards-in-2021-7">Top Wing Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-power-forwards-in-2021-9">Top Power Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-centers-in-2021-7">Top Centers</a></p><p> <a href="https://iowapreps.rivals.com/news/class-of-2021-basketball-top-prospect-database-4">2021 Top Player Database</a></p><p>Top Class of 2018 Players</p><p> <a href="https://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Top 225 Players in 2018</a></p><p> <a href="https://iowapreps.rivals.com/news/top-point-guards-in-2018-49">Top Point Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-guards-in-2018-34">Top Wing Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-forwards-in-2018-34">Top Wing Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-power-forwards-in-2018-48">Top Power Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-centers-in-2018-47">Top Centers</a></p><p> Top 10 Candidates in 2020</p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-1">Part 1</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-2">Part 2</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-3">Part 3</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-4">Part 4</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-5">Part 5</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-6">Part 6</a></p><p> <a href="https://iowapreps.rivals.com/news/top-10-basketball-candidates-in-2020-part-7">Part 7</a></p><p>Top Class of 2019 Players</p><p> <a href="https://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Top 175 in Players 2019</a></p><p> <a href="https://iowapreps.rivals.com/news/top-point-guards-in-2019-33">Top Point Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-guards-in-2019-22">Top Wing Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-forwards-in-2019-25">Top Wing Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-power-forwards-in-2019-31">Top Power Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-centers-in-2019-32">Top Centers</a></p><p> <a href="https://iowapreps.rivals.com/news/class-of-2019-basketball-top-prospect-database-6"> 2019 Top Player Database</a></p><p> Midseason All State</p><p> <a href="https://iowapreps.rivals.com/news/freshmen-midseason-all-state-basketball-first-team-4">Freshmen, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-midseason-all-state-basketball-second-team-5">Freshmen, Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/freshmen-midseason-all-state-basketball-third-team-3">Freshmen, Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-midseason-all-state-basketball-first-team-3">Soph, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-midseason-all-state-basketball-second-team-3">Soph, Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/sophomore-midseason-all-state-basketball-third-team-1">Soph, Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-midseason-all-state-basketball-first-team-1">Junior, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-midseason-all-state-basketball-second-team-1">Junior, Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/junior-midseason-all-state-basketball-third-team-1">Junior, Third Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-4a-midseason-all-state-basketball-first-team-6">4A, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-4a-midseason-all-state-basketball-second-team-6">4A, Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-3a-midseason-all-state-basketball-first-team-6">3A, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-3a-midseason-all-state-basketball-second-team-6">3A, Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-2a-midseason-all-state-basketball-first-team-6">2A, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-2a-midseason-all-state-basketball-second-team-6">2A, Second Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-1a-midseason-all-state-basketball-first-team-6">1A, First Team</a></p><p> <a href="https://iowapreps.rivals.com/news/class-1a-midseason-all-state-basketball-second-team-6">1A, Second Team</a></p><p> Top Class of 2020 Players</p><p> <a href="https://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Top 100 in Players 2020</a></p><p> <a href="https://iowapreps.rivals.com/news/top-point-guards-in-2020-18">Top Point Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-guards-in-2020-13">Top Wing Guards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-wing-forwards-in-2020-13">Top Wing Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-power-forwards-in-2020-18">Top Power Forwards</a></p><p> <a href="https://iowapreps.rivals.com/news/top-centers-in-2020-18">Top Centers</a></p><p> <a href="https://iowapreps.rivals.com/news/class-of-2020-basketball-top-prospect-database-5"> 2020 Top Player Database</a></p><p> In-Season Coverage</p><p> <a href="https://iowapreps.rivals.com/news/new-basketball-names-to-watch-class-of-2021">New 2021 Names to Watch</a></p><p> <a href="https://iowapreps.rivals.com/news/new-basketball-names-to-watch-class-of-2020">New 2020 Names to Watch</a></p><p> <a href="https://iowapreps.rivals.com/news/new-basketball-names-to-watch-class-of-2019">New 2019 Names to Watch</a></p><p> <a href="https://iowapreps.rivals.com/news/new-basketball-names-to-watch-class-of-2018">New 2018 Names to Watch</a></p><p> Most Recruited Players, All Classes</p><p> <a href="https://iowapreps.rivals.com/news/iowa-s-most-recruited-basketball-players-1-5--6">Rankings 1-5</a></p><p> <a href="https://iowapreps.rivals.com/news/iowa-s-most-recruited-basketball-players-6-10--8">Rankings 6-10</a></p><p> <a href="https://iowapreps.rivals.com/news/iowa-s-most-recruited-basketball-players-11-15--5">Rankings 11-15</a></p><p> <a href="https://iowapreps.rivals.com/news/iowa-s-most-recruited-basketball-players-16-20--5">Rankings 16-20</a></p><p> <a href="https://iowapreps.rivals.com/news/iowa-s-most-recruited-basketball-players-21-25--5">Rankings 21-25</a></p><p> <a href="https://iowapreps.rivals.com/news/iowa-s-most-recruited-basketball-players-26-30--4">Rankings 26-30</a></p><p> Mr. Basketball Rankings</p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-1-1">Candidate #1</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-2-1">Candidate #2</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-3-1">Candidate #3</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-4-1">Candidate #4</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-5-1">Candidate #5</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-6-1">Candidate #6</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-7-1">Candidate #7</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-8-1">Candidate #8</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-9-1">Candidate #9</a></p><p> <a href="https://iowapreps.rivals.com/news/2017-2018-mr-basketball-candidate-10-1">Candidate #10</a></p><p>  Elite Player Rankings</p><p> <a href="https://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Top 225 in Players 2018</a></p><p> <a href="https://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Top 180 in Players 2019</a></p><p> <a href="https://iowapreps.forums.rivals.com/threads/boys-basketball-player-rankings-top-players-by-position-more.4106/">Top 110 in Players 2020</a></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1/printable' site-name='IowaPreps.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":1}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' scoreboard-photos-id='15106' scoreboard-scores-id='15105' site='{"id":54,"legacy_id":978,"name":"IowaPreps.com","friendly_name":"Iowa HS Sports","annual_discount":null,"subdomain":"iowapreps","primary_color":"000000","secondary_color":"b22222","font_color":"ffffff","short_name":"iowapreps","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81735490-1"}' twitter-feed='{"id":54,"site_id":54,"handle":null,"list_name":null,"created_at":"2016-02-01T12:24:57.618-06:00","updated_at":"2016-02-01T12:24:57.618-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1/printable' site-name='IowaPreps.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719658', 'https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Top 250 Basketball Players in 2018 (31-35)";
  _sf_async_config.sections = 'content,content-basketball,content-basketball-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://iowapreps.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719658",
    c7: "https://iowapreps.rivals.com/news/top-250-basketball-players-in-2018-31-35--1"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fiowapreps.rivals.com%2Fnews%2Ftop-250-basketball-players-in-2018-31-35--1&c5=2022719658&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
